Главная страница

Mass Effect 2
Мануал для Mass Effect 2 по редактированию Coalesced.ini
и работае в редакторе сохранений

Помощь

Рекомендуется к посещению
ARS Mod

© Dark_XSM - 2010г.
По вопросам и предложениям обращаться ко мне в ICQ - 436120541

Mass Effect 2 Coalesced- and Save-editing manual v1.0.4
13.03.2010


Броня
Здесь содержится информация о добавлении моделей брони и одежды для ношения Шепард(ом).
[+] Основы добавления брони
Для начала нужно иметь прогу UModel и выбрать файл в котором собираешься искать модели.
Скажу сразу: модели имеются далеко не в каждом файле.
К примеру выберем файл Mass Effect 2\BioGame\CookedPC\BioD_ProNor.pcc
Его нужно куда-нить скопировать, что бы лежал там один, и переименовать в BioD_ProNor.upk
Теперь запускаешь программу UModel через umodelGUI.exe,
и указываешь папку в которой лежит файл BioD_ProNor.upk
Когда файл наконец соизволит загрузиться, ищи в колонке File Type строки со значением SkeletalMesh.
Что бы посмотреть модель ткни на него 2 раза(не двойным щелчком).
Например на HMM_ARM_HVYb_MDL Полюбовался на корявую модельку брони без текстур?
В игре оно выглядит куда лучше, согласен.
Теперь посмотри в правом нижнем окне последние записи(самые верхнии).
Видишь там BIOG_HMM_ARM_HVY_R.HMM_ARM_HVYb_MDL? Это почти то что тебе надо.
Выделенный красным кусок обозначает к какому разделу относится модель.
В основном всё что можно добавить в качестве брони - отдельные модели, уже "собранная" броня и одежда
(иногда в качестве одежды могут выступить тела NPC)

В секции [SFXGame.SFXPawn_Player] добавить описание, к примеру:

Рассмотрим эту строку поближе:
Cамое главное: BIOG_HMF_ARM_HVY_R.HVYb.HMF_ARM_HVYb_MDL
BIOG_HMF_ARM_HVY_R - файл из которого нужно грузить модель.
HVYb - раздел из которого её нужно грузить.
HMF_ARM_HVYb_MDL - модель которую нужно грузить.

[+] ***Appearances

CasualAppearances - если модель нужно использовать на Нормандии
[+] TorsoAppearances - для надевания брони как составного элемента

Во избежании такого косяка как накладывание рук брони на родные руки ГГ
(хорошо заметно при модели Легиона) необходимо добавить строки
ShoulderAppearances=(Id=[Любой незанятый ID],Type=CustomizableType_Shoulders,PlotFlag=-1)
ArmAppearances=(Id=[Любой незанятый ID],Type=CustomizableType_Arms,PlotFlag=-1)
LegAppearances=(Id=[Любой незанятый ID],Type=CustomizableType_Legs,PlotFlag=-1)

(в случае если хочется с какой-нибудь бронёй потаскать шлем)
FullBodyAppearances - означает что этот элемент является полной бронёй. У неё нет составных элементов.

Id - идентификационный номер элемента. К нему 2 требования: он не может быть отрицательным,
и он не должен совпадать с другими ID элементов того-же типа.
Type - обозначает к какому типу относится объект. В данном случае это "торс"
(хотя для FullBodyAppearances это, вроде, роли не играет)
Mesh - модели и текстуры(***MaterialOverride) брони для мужского(Male) и женского персонажей(Female).
[+] GameEffects - эффект который даёт элемент. В данном случае это SFXGame.SFXGameEffect_Gear_PowerBelt,
в игре он даёт бонус неизвестен.

SFXGame.SFXGameEffect_Gear_N7Torso
SFXGame.SFXGameEffect_Gear_CapacitorChestplate
SFXGame.SFXGameEffect_Gear_BodyArmor
SFXGame.SFXGameEffect_Gear_PowerBelt
SFXGame.SFXGameEffect_Gear_N7Shoulders
SFXGame.SFXGameEffect_Gear_AmplifierPads
SFXGame.SFXGameEffect_Gear_StrengthBoostPads
SFXGame.SFXGameEffect_Gear_HeavyLeftSideArmor
SFXGame.SFXGameEffect_Gear_N7Arms
SFXGame.SFXGameEffect_Gear_StabilizationGauntlets
SFXGame.SFXGameEffect_Gear_HeavyDampingGauntlets
SFXGame.SFXGameEffect_Gear_LeftArmAmmoPack
SFXGame.SFXGameEffect_Gear_N7Legs
SFXGame.SFXGameEffect_Gear_StimulatorConduits
SFXGame.SFXGameEffect_Gear_LifeSupportWebbing
SFXGame.SFXGameEffect_Gear_EquipmentPacks
SFXGame.SFXGameEffect_Gear_N7Helmet
SFXGame.SFXGameEffect_Gear_N7Helmet
SFXGame.SFXGameEffect_Gear_Visor
SFXGame.SFXGameEffect_Gear_DeathMask

SFXGameDLC_PRE_Cerberus.SFXGameEffect_Gear_CerberusHealthBonus
SFXGameDLC_PRE_Cerberus.SFXGameEffect_Gear_CerberusHvyWpnMagazines
SFXGameDLC_PRE_Cerberus.SFXGameEffect_Gear_CerberusShieldBonus

SFXGameDLC_PRE_Collectors.SFXGameEffect_Gear_CollectorsHealthBonus
SFXGameDLC_PRE_Collectors.SFXGameEffect_Gear_CollectorsRegenBonus
SFXGameDLC_PRE_Collectors.SFXGameEffect_Gear_CollectorsStormSpeed

SFXGameContentDLC_PRE_DA.SFXGameEffect_Gear_DA_PowerBonus
SFXGameContentDLC_PRE_DA.SFXGameEffect_Gear_DA_ShieldBonus

SFXGameDLC_PRE_Gamestop.SFXGameEffect_Gear_TerminusShieldBonus
SFXGameDLC_PRE_Gamestop.SFXGameEffect_Gear_TerminusStormSpeed
SFXGameDLC_PRE_Gamestop.SFXGameEffect_Gear_TerminusWpnMagazines

SFXGameDLC_PRE_General.SFXGameEffect_Gear_InfernoNegotiationBonus
SFXGameDLC_PRE_General.SFXGameEffect_Gear_InfernoPowerDamage
SFXGameDLC_PRE_General.SFXGameEffect_Gear_InfernoStormSpeed

SFXGameContentDLC_PRO_Gulp01.SFXGameEffect_Gear_GulpHelmet

SFXGameContentDLC_PRO_Pepper01.SFXGameEffect_Gear_Pepper01Helmet

SFXGameContentDLC_PRO_Pepper02.SFXGameEffect_Gear_Pepper02Helmet
необходима информация о бонусах

PlotFlag - флаг устанавливаемый игрой и обозначающий что элемент доступен для выбора в ящике с бронёй.
При значении -1 элемент доступен всегда.

Не все модели доступны просто так. Некоторые модели придётся грузить отдельно. Делается это так:
[Engine.PackagesToAlwaysCook]
SeekFreePackage=[название файла]
К примеру для модели Легиона название файла - BioH_geth_01
В случае если модель не обрабатывается "по дефолту", придётся выключить фоновую обработку текстур.
В списке [Engine.Engine] найти строчку bUseBackgroundLevelStreaming и поменять значение True на False
Это сильно увеличит время загрузки сохранений и при переходах, и может пропасть фоновый звук на Нормандии.
[+] Примеры брони/одежды
Поиграцо за Тали и/или Миранду:

[Engine.PackagesToAlwaysCook]
SeekFreePackage=BioH_Tali_00
SeekFreePackage=BioH_Vixen_00

FullBodyAppearances=(Id=[Любой незанятый ID],Type=CustomizableType_Torso,Mesh=(Female="BIOG_HMF_ARM_NKD_R.NKDb.HMF_ARM_NKDb_MDL"),PlotFlag=-1)
[Engine.PackagesToAlwaysCook]
SeekFreePackage=BioD_Nor_002CabinKelly

Почувствовать себя дырявым гетом(Легионом) можно добавив это:
[Engine.PackagesToAlwaysCook]
SeekFreePackage=BioH_geth_00
SeekFreePackage=BioH_END_geth_00
SeekFreePackage=BioH_geth_01
SeekFreePackage=BioH_END_geth_01

На главную


Оружие
Здесь содержится информация о добавлении и редактировании оружия.
[+] Изменение набора оружия у Шепард(а) и сопартийцев
Строка в которой написано какое оружие какой класс должен таскать выглядит примерно так:
PlayerLoadoutInfo=(ClassName=SFXPawn_PlayerAdept,WeaponClasses=(LoadoutWeapons_HeavyPistols,LoadoutWeapons_AutoPistols,LoadoutWeapons_HeavyWeapons))
Красным выделен класс, розовым оружие которым он может пользоваться.

Класс - Название на русском
Adept - Адепт
Engineer - Инжинер
Soldier - Солдат
Sentinel - Страж
Infiltrator - Разведчик
Vanguard - Штурмовик

Класс оружия - Название на русском
LoadoutWeapons_HeavyPistols - Тяжёлые пистолеты
LoadoutWeapons_AutoPistols - Пистолеты-Пулемёты
LoadoutWeapons_Shotguns - Дробовики
LoadoutWeapons_AssaultRifles - Штурмовые винтовки
LoadoutWeapons_SniperRifles - Снайперские винтовки
LoadoutWeapons_HeavyWeapons - Тяжёлое оружие

К примеру ты хочешь дать Стражу всё оружие, для чего Пистолет-Пулемёт нужно заменить на дробовик,
и добавить Штурмовую и Снайперскую винтовки. Для этого надо взять строку
PlayerLoadoutInfo=(ClassName=SFXPawn_PlayerSentinel,WeaponClasses= (LoadoutWeapons_HeavyPistols,LoadoutWeapons_AutoPistols,LoadoutWeapons_HeavyWeapons))
и превращаем её в это:
PlayerLoadoutInfo=(ClassName=SFXPawn_PlayerSentinel,WeaponClasses= (LoadoutWeapons_HeavyPistols,LoadoutWeapons_Shotguns,LoadoutWeapons_AssaultRifles, LoadoutWeapons_SniperRifles,LoadoutWeapons_HeavyWeapons))

Аналогично делается для сопартицев, их оружие хранится в строках типа
HenchLoadoutInfo=(ClassName=SFXPawn_Garrus,WeaponClasses=(LoadoutWeapons_AssaultRifles,LoadoutWeapons_SniperRifles))
[+] Изменение доступности оружия
Что бы сделать оружие доступным с самого начала найдите строки типа этой:
AssaultRifles=(ClassName="SFXGameContent_Inventory.SFXWeapon_Needler",UnlockPlotID=Wpn_AssaultRifle2)
и удалите параметр UnlockPlotID=Wpn_AssaultRifle2
К примеру что бы вторая штурмовая винтовка была доступна сразу, нужно строку
AssaultRifles=(ClassName="SFXGameContent_Inventory.SFXWeapon_Needler",UnlockPlotID=Wpn_AssaultRifle2)
превратить в такую:
AssaultRifles=(ClassName="SFXGameContent_Inventory.SFXWeapon_Needler")

А что бы сделать супер-оружие доступным для сопартийцев нужно таким-же образом удалить строки bNotRegularWeaponGUI=true
К примеру, из такой строки:
Shotguns=(ClassName="SFXGameContent_Inventory.SFXWeapon_FlakGun",bNotRegularWeaponGUI=true)
сделать такую:
Shotguns=(ClassName="SFXGameContent_Inventory.SFXWeapon_FlakGun")

Если-же хочешь получить супер-оружие "честно" то:
В оригинале супер-пушку можно получить только если ГГ уже владеет выбираеммым классом оружия.
К примеру солдат без проблем получит любую супер-пушку, а адепт только научится пользоваться обычным оружием такого класса.
Что бы любым классом получить бонусную супер-пушку заменить строки
PlayerSpecialWeapons=(WeaponClassName="SFXGameContent_Inventory.SFXWeapon_MachineGun",UnlockPlotName=Wpn_SuperAssaultRifle)
PlayerSpecialWeapons=(WeaponClassName="SFXGameContent_Inventory.SFXWeapon_FlakGun",UnlockPlotName=Wpn_SuperShotgun)
PlayerSpecialWeapons=(WeaponClassName="SFXGameContent_Inventory.SFXWeapon_MassCannon",UnlockPlotName=Wpn_SuperSniperRifle)
На
PlayerSpecialWeapons=(WeaponClassName="SFXGameContent_Inventory.SFXWeapon_MachineGun",UnlockPlotName=Wpn_BonusAssaultRifle)
PlayerSpecialWeapons=(WeaponClassName="SFXGameContent_Inventory.SFXWeapon_FlakGun",UnlockPlotName=Wpn_BonusShotgun)
PlayerSpecialWeapons=(WeaponClassName="SFXGameContent_Inventory.SFXWeapon_MassCannon",UnlockPlotName=Wpn_BonusSniperRifle)

Если ты уже выбрал бонусное оружие, и хочешь изменить решение, то в файле Coalesced.ini в разделе [SFXGame.SFXGameModeDefault] добавить одну из следующих строк:
Для получения/замены на дробовик: Bindings=( Name="[любая незанятая кнопка]", Command="setintbyname Wpn_BonusAssaultRifle 0 | setintbyname Wpn_BonusSniperRifle 0 | setintbyname Wpn_BonusShotGun 1" )
Для получения/замены на автомат: Bindings=( Name="[любая незанятая кнопка]", Command="setintbyname Wpn_BonusAssaultRifle 1 | setintbyname Wpn_BonusSniperRifle 0 | setintbyname Wpn_BonusShotGun 0" )
Для получения/замены на снайперку: Bindings=( Name="[любая незанятая кнопка]", Command="setintbyname Wpn_BonusAssaultRifle 0 | setintbyname Wpn_BonusSniperRifle 1 | setintbyname Wpn_BonusShotGun 0" )
[+] Получение вражеского оружия
Что бы получить оружие некоторых врагов, необходимо добавть в раздел [SFXGame.SFXEngine] строку
DynamicLoadMapping=(ObjectName="SFXGameContent_Inventory.ID пушки",
SeekFreePackageName="архив откуда грузить пушку")

В раздел [SFXGame.SFXPlayerSquadLoadoutData] добавить строку
HeavyWeapons=(classname="SFXGameContent_Inventory.ID пушки")

Найти раздел [SFXGameContent_Inventory.ID пушки] и добавить в него строки
MagSize=(X=500,Y=500) - если нет параметра MagSize
GUIImage=GUI_Codex_Images.название оружия_512 - картинка оружия, чисто для "отличить"

ID пушки - архив
SFXHeavyWeapon_ScionGun - BioP_HorCr1
SFXHeavyWeapon_OculusParticleBeam - BioP_EndGm1
SFXHeavyWeapon_RocketLauncher - BioP_BlbGtl
SFXHeavyWeapon_RapidRocketLauncher - BioP_BlbGtl
SFXHeavyWeapon_FlameThrower - BioP_OmgPrA
SFXWeapon_MiniGun - BioP_ProCer
SFXHeavyWeapon_PraetorianParticleBeam - BioD_HorCr1_302Spaceport

[+]Названия пушек для картинок

AssaultRifle
Needler
Machinegun
GethPulseRifle
Shotgun
HeavyShotgun
FlakCannon
MachinePistol
Sub-MachineGun
HeavyPistol
HandCannon
SniperRifle
Anti-MaterialRifle
MassCannon
GrenadeLauncher
MissileLauncher
CryoGun
NukeLauncher
ParticleBeam


Прочее
Здесь содержится информация о разных полезностях.
[+] Убрать логотипы производителя и издателя при загрузке игры
В секции [FullScreenMovie] закомментить первые три строчки
;StartupMovies=BWLogo
;StartupMovies=ME_EAsig_720p_v2_raw
;StartupMovies=publisher
Плюс можно исправить маленький косяк с непропускающимся видео при взлёте с Иллиума вставив строку SkippableMovies=TWRHub_Dept
[+] Назначение команд на кнопки
В секции [SFXGame.SFXGameModeDefault] после последней строки вставить
Bindings=( Name="[любая незанятая кнопка]", Command="[команда]" )

Известные команды(# - произвольное число): givetalentpoints # - получить очки умений (не более 99)
initeezo # | initiridium # | initplatinum # | initpalladium # - получить по # единиц каждого ресурса
Соотв: Нулевой элемент | Иридий | Платина | Палладий
giveXP # - получить # опыта
setparagon # - установить значение положительной кармы (максимум по умолчанию 1957)
setrenegade # - установить значение отрицательной кармы (максимум по умолчанию 1900)
god - бессмертие(работает в пределах миссии)
initammo # - получить термозаряды
Ghost - летать сквозь стены
Walk - ходить по полу
ToggleFlyCam - переключение свободной камеры. Полетать камерой по уровню, рассмотреть ГГ или его спутниц...
Slomo # - скорость времени. 1 - норма, 0.5 - замедление времени на половину.
screenshot - сделать скриншот, складываются в папку ..\Documents\BioWare\Mass Effect 2\BIOGame\Screenshots

Bindings=( Name="[любая незанятая кнопка]",
Command="set SFXPawn_Player bWantsToCrouch true | OnRelease set SFXPawn_Player bWantsToCrouch false" ) позволяет присесть нажав указанную кнопку. Как сделать переключение как было в первой ME не ясно
[+] Полезная и любопытная информация
Большое поле для читерской деятельности предоставляют следующие секции Coalesced.ini:
[+] [SFXGame.BioArtPlaceable] - настройки времени и др. условий исчезновения трупов

m_nMaxCorpseVisibilityCleanupAttempts - количество трупов. если их становится больше, проходит первая "волна" чистки
m_fCorpseCleanupFirstAttemptTime - время, после которого начинают исчезать трупы
m_fCorpseCleanupAttemptRetryTime - время между исчезновением трупов
m_fMaxCorpseCleanupDistanceThreshold - дистанция, на которой исчезают трупы, в сантиметрах
m_fMaxCorpseCleanupScreenSizeThreshold - тут интересная вещь. устанавливается место на экране (хз в чем оно выражено).

[+] [SFXGame.SFXDifficulty_Level1]-[SFXGame.SFXDifficulty_Level6] - уровни сложности игры.

PlayerShieldRechargeModifier - модификатор скорости восстановления щита игрока. Чем выше значение тем быстрее щит будет восстанавливаться.
EnemyHealthMultiplier(Low-Hight) - множитель здоровья врага. Чем больше число тем больше здоровья.
PlayerHealthMultiplier(Low-Hight) - множитель здоровья игрока.
HenchHealthMultiplier(Low-Hight) - множитель здоровья напарников.
FriendlyHealthMultiplier(Low-Hight) - множитель здоровья "друзей".
EnemyPowerCooldownMultiplier - множитель перезарядки умений врага. Чем больше число тем быстрее умения перезаражаются.
SquadPowerDurationMultiplier - множитель продолжительности действия умений десантной группы игрока.
SquadPowerCooldownMultiplier - множитель перезарядки умений десантной группы игрока.

[SFXGame.SFXDroppedAmmo] - PctAmmoGiven=0.25
процент пополнения боеприпасов найденными термозарядами
[SFXGameContent.SFXSeqAct_NewGameBonuses] - бонусы,
получаемые при импорте ГГ из первой части Mass Effect
[SFXGame.SFXGame] - например, StormStamina=4.0 и StormRegen=0.8
скорость ускорения и его регенерации во время боя
[SFXGame.SFXGameConfig] - максимальный уровень ГГ и кол-во опыта
[SFXGameContent.BioSeqAct_GiveMissionXP] - кол-во опыта за прохождение миссий и квестов
[SFXGame.SFXInventoryManager] - настройки инвентаря
[SFXGameContent_Inventory.SFXWeapon_AssaultRifle] и далее - настройки оружия
[SFXGame.SFXPawn_Player] - если параметрах с TorsoAppearances по HelmetAppearances значения PlotFlag изменить на -1, то с начала игры в шкафчике для прони будут доступны все части брони N7
(из магазинов они не пропадут)
[SFXGame.BioSFHandler_PartySelection] - если в строках строчках lstAppearances значения PlotFlag изменить на -1, то альтернативные костюмы напарников будут доступны и без прохождения их заданий

bAllowMatureLanguage=FALSE - запрет на "нецензурные выражения". При выключении(заменить False на True) вроде бы ничего не происходит, но достоверной информации нет.

Если ты пользовался какой-то левой фигнёй которая обещала дать все улучшения, и после этого корабль перестал улучшаться, то в разделе [SFXGame.SFXGameModeDefault] добавь строку
Bindings=( Name="[любая незанятая кнопка]", Command="setintbyname Tec_GruntShotgun 0 | setintbyname Tec_JackUpgrade 0 | setintbyname Tec_LegionSniper 0 | setintbyname Tec_MordinUpgrade 0 | setintbyname Tec_ShipArmor 0 | setintbyname Tec_ShipFuel 0 | setintbyname Tec_ShipGun 0 | setintbyname Tec_ShipProbes 0 | setintbyname Tec_ShipScanner 0 | setintbyname Tec_ShipShield 0" )
И в игре нажать указанную тобо кнопку.

Если ты хочешь что бы у Шепард(а) шрамы "усиливались" не только когда ты играешь за Отступника,
но и когда играешь за Героя, то замени
на
[+] Для "пропатчивания" своего ini-файла, если в нём содержится сборка которую жалко терять/лень снова собирать
2=3339519335.000000 заменено на 2=3342481716.000000

После строк
[BioLocalization]
Server=BWE-SQLPROD3
Database=bw_me2_content
добавлено
DefaultTestStringFlag=0

1=5337178953.000000 заменено на 1=5342193689.000000

Bindings=( Name="PC_VehicleMine", Command="Toggle bMine" )
заменено на
Bindings=( Name="PC_VehicleMine", Command="Button bMine" )

Bindings=( Name="RightMouseButton", Command="Vehicle_Camera" )
заменено на
Bindings=( Name="MiddleMouseButton", Command="Vehicle_Camera" )

Все строки
LocalizedBindings=( Name="E", Command="Vehicle_Jump" )
LocalizedBindings=( Name="V", Command="PC_VehicleMine" )
заменены на
LocalizedBindings=( Name="LeftShift", Command="Vehicle_Jump" )
LocalizedBindings=( Name="RightMouseButton", Command="PC_VehicleMine" )


Редактор сохранений
Здесь содержится информация о работае в редакторе сохранений.
[+] Изменение внешности
Внимание: не работает с типовой внешностью.

[+]Изменение причёски

Если прическа выглядит размыто или еще что-то не так, нужно после ее смены залезть в
raw->Player->Appearance->Morph Head->Texture Parameters и поставить текстуры HAIR_Diff и HAIR_Norm
Например: прическа BIOG_HMF_HIR_PRO.Sexy.HMF_HIR_Sxy_MDL,
текстуры для нее соответственно будут
BIOG_HMF_HIR_PRO.Sexy.HMF_HIR_Sxy_Diff и BIOG_HMF_HIR_PRO.Sexy.HMF_HIR_Sxy_Norm

В строке Morph Head => Hair Mesh можно поменять прическу ГГ

Женские
BIOG_HMF_HIR_PRO.Mom.HMF_HIR_Mom_MDL - как у Кели
BIOG_HMF_HIR_PRO.Sexy.HMF_HIR_Sxy_MDL - девушка из миссии Джейкоба
BIOG_HMF_HIR_PRO.Cyberbabe.HMF_HIR_Cyb_MDL
BIOG_HMF_HIR_PRO.Mohawk.HMF_HIR_Mhk_MDL
BIOG_HMF_HIR_PRO.Afro.HMF_HIR_Afr_MDL
BIOG_HMF_HIR_PRO.Ashley.HMF_HIR_PROAshley_MDL
BIOG_HMF_HIR_PRO.Classy.HMF_HIR_Cls_MDL
BIOG_HMF_HIR_PRO.Cute.HMF_HIR_Cte_MDL
BIOG_HMF_HIR_PRO.HighBun.HMF_HIR_Hbn_MDL
BIOG_HMF_HIR_PRO.Iconbun.HMF_HIR_IBun_MDL
BIOG_HMF_HIR_PRO.LowBun.HMF_HIR_Lbn_MDL
BIOG_HMF_HIR_PRO.LowBun.HMF_HIR_Mbu_MDL
BIOG_HMF_HIR_PRO.MidBun.HMF_HIR_Mbn_MDL
BIOG_HMF_HIR_PRO.PonyTail.HMF_HIR_Ptl_MDL
BIOG_HMF_HIR_PRO.PROCustomAfro.HMF_HIR_PROCustom_Afr_MDL
BIOG_HMF_HIR_PRO.PROCustomCute.HMF_HIR_PROCustom_Cute_MDL
BIOG_HMF_HIR_PRO.PROCustomSexy.HMF_HIR_PROCustom_Sexy_MDL
BIOG_HMF_HIR_PRO.Short02.HMF_HIR_PROShort_MDL

Эшли:
BIOG_HMF_HIR_PRO.Ashley.HMF_HIR_PROAshley_MDL

Мужские
BIOG_HMM_HIR_PRO.FormalSpikes.HMM_HIR_Fsk_MDL
BIOG_HMM_HIR_PRO.Mohawk.HMM_HIR_Mhk_MDL
BIOG_HMM_HIR_PRO.RollinsSpike.HMM_HIR_Rsk_MDL
BIOG_HMM_HIR_PRO.SargeSpike.HMM_HIR_Ssk_01_MDL
BIOG_HMM_HIR_PRO.SargeSpike.HMM_HIR_Ssk_02_MDL
BIOG_HMM_HIR_PRO.Short01.HMM_HIR_PROShort01_MDL
BIOG_HMM_HIR_PRO.Short02.HMM_HIR_PROShort02_MDL
BIOG_HMM_HIR_PRO.Short03.HMM_HIR_PROShort03_MDL

Кайден:
BIOG_HMM_HIR_PRO.Kaiden.HMM_HIR_Kai_MDL

Изменить цвет можно в HED_Hair_Colour_Vector и бровей HED_Addn_Colour_Vector

[+]Изменение цвета глаз

Red eyes (normal): R=0,1, G=0,0, B=0,0, A=1
Red eyes (light): 0,9, 0,0, 0,0, 1
Red eyes (glowing): 0,10, 0,0, 0,0, 1
Red eyes (spooky): 0,20, 0,0, 0,0, 1

Blue eyes (unnatural): 0,0, 0,0, 0,1, 1
Blue eyes (artificial): 0,0, 0,0, 0,9, 1
Blue eyes (glowing): 0,0, 0,0, 0,10, 1
Blue eyes (spooky): 0,0, 0,0, 0,20, 1

Purple eyes (light): 1, 1, 6, 1
Purple eyes (glowing): 1, 1, 10, 1

Grey eyes (normal): 0,7893139, 0,7372048, 0,6592241, 1
Gray eyes (nearly white) 0,9893138, 0,9372048, 0,9592241, 1

White eyes (glowing): 10, 10, 10, 1
White eyes (spooky): 20, 20, 20, 1

Yellow eyes (glowing): 10, 10, 0, 1

Что бы сделать глаза абсолютно чёрными:
Field: EYE_Iris_Colour_Vector: 0, 0, 0, 1
Field: EYE_White_Colour_Vector: 0, 0, 0, 1

Что бы вернуть нормальные глаза:
EYE_White_Colour_Vector (original value): 0,7893139, 0,6372048, 0,5592241, 1

Field: EYE_Iris_Colour_Vector: 5, 5, 20, 1
Field: EYE_White_Colour_Vector: 5, 5, 20, 1

[+]Изменение цвета кожи

Vampire skin: 0,9592996, 0,7488649, 0,6083597, 1
Normal skin (whitish): 0,9592996, 0,6488649, 0,5083597, 1
Normal skin (basic): 0,7592996, 0,3488649, 0,2083597, 1
Normal skin (lighter): 0,9592996, 0,4488649, 0,3083597, 1
Gray skin: 0,3488649, 0,3488649, 0,3488649, 1
Eyeball skin: 0,7893139, 0,6372048, 0,5592241, 1
Ice queen: 1, 1, 4, 1

[+]Полноценное изменение внешности

1. Идём в папку с игрой Mass Effect 2\Binaries. Создаём ярлык на MassEffect2.exe,
заходим в свойства ярлыка, в поле "Объект" в конце добавляем BioP_Char
2. Этот пункт можно пропустить, если вы хотите сделать абсолютно новую внешность.
Если хотите что-то подправить вам нужен код внешности.
Открываем "Редактор сохранённых игр/Save Editor" выбираем сохранёнку с вашим персонажем,
на вкладке "Raw" во втором пункте нажимаем на + возле "Player", строчка "Face Code" то,
что нам нужно, выделяем, копируем код.
3. Заходим в игру по ярлыку из первого пункта, сразу попадаем в редактор персонажа,
заходим в редактор внешности, вставляем внизу код внешности вашего персонажа, если нужно,
меняем что нужно.
4. Если внешность устраивает, сохраняем, пропускаем быстро все другие пункты, начинается новая игра.
5. Сворачиваем игру, идём в редактор сохранений, ищем вашего нового Шепарда,
в папке два файла сохранений, автосохранение и перезапуск миссии, выбираем любой.
На вкладке "Toolbox" нажимаем кнопку "Export" это файл с новой внешностью, сохраняем куда удобнее.
Больше новый Шепард не понадобится.
6. Всё тем же редактором сохранений открываем сохранёнку с вашим старым Шепардом,
на вкладке "Toolbox" нажимаем "Import" выбираем сохранённую, в пункте пять, внешность, сохраняем.
7. Заходим в игру, загружаем вашего старого Шепарда с новым лицом, смотрим в диалогах,
что что-то не так, возвращаемся к пункту один
[+] Добавление способностей
[+]Добавление способностей. Вариант 1

"Добавить можно так: открываешь сейв (забэкапься только), тебе в секцию loadout, структура Player->Powers. Справа кнопка открывающая список скилов. Ниже списка кнопка "добавить". ClassName - берешь отсюда: [SFXGameCookerHelper.PowerStandalonePackages] к примеру это будут SFXGameContent_Powers.SFXPower_WarpAmmo_Player.
Current Rank - оставляй 0, Name - соответственно WarpAmmo (если что посдмотри название скилла у компаньонов, секция Squad, структура Henchman->Powers), WheelDisplayIndex - да хоть бы и 6, не принципиально. Все. Сохраняй это дело заходи в игру и получай осьмой навык.
Способ кривой, косой, но пока единственно рабочий. Меня лично это дело не устраивает, так как хотелось бы НАСТРАИВАТЬ свой класс (в идеале вообще создать его с нуля с нужными только тебе способностями), а не делать из него многорукое многоголовое и многоскилловое (у)божество. А так - читерам раздолье. Только помните, господа, о том, что активных скиллов может быть только 8, и один из слотов занят "Единством". Пассивки же классовые можно кажись добавлять безнаказанно (не проверял, но не вижу причин почему бы и нет)."

[+]Добавление способностей. Вариант 2

1. Жмёшь Raw => секция Squad => жмёшь на + рядом с Player => ищем строчку с Powers, жмём на неё => справа появляется кнопка перехода, клацаем туда
2. Открывается табличка Power Collection Editor. В левой табличке ваши способности, чтобы добавить умения жмём Add, появилась новая строчка, теперь редактируем
3. вот список бонусных способностей: ArmorPiercingAmmo, Barrier, Crush, Fortification, GethShieldBoost, Reave, ShieldJack, WarpAmmo, NeuralShock, Dominate, AntiOrganicAmmo.
Далее, в Class name пишем SFXGameContent_Powers.SFXPower_Умение_Player , вместо "Умение" выбираем любое из вышенаписанного списка.
В Current rank ставим 0, в name способность, которую выбрали, в Wheel Display Index ставим значение 5
4. Жмём ОК, сохраняем, переписываем последнее ваше сохранение.


Помощь
Здесь содержится информация о программах необходимых для модифицирования конфигураций игры.

(Показать/Скрыть текст)
Для редактирования файла Coalesced.ini

Notepad++ - программа для редактирования файла Coalesced.ini.
ВНИМАНИЕ
При редактровании файла другими программами могут быть(и будут) ошибки влияющие на стабильность игры.

Ruby - программа для запуска скриптов rb, такой скрипт будет использоваться для фиксинга файла Coalesced.ini

В комплекте идёт архив ME2 files.rar, в нём содержится rb-скрипт и оригинальные файлы Coalesced.ini версий 1.0 и 1.01
Распакуйте скрипт в папку с игрой где находится файл Coalesced.ini
Пример: "E:\Mass Effect 2\BioGame\Config\PC\Cooked"

Надеюсь, ты не просто попялился на программы по первым двум ссылкам, а скачал и установил. Если так, то всё готово к редактированию основного конфига игры. Программой Notepad++ файл нужно редактировать, после редактирования запустить файл me2_fix_ini.rb и подождать пока запущенная им программа не закроется(обычно в пределах 5 секунд).

(Показать/Скрыть текст)
Для редактирования сохранений

скачать нужно это: Gibbed ME2 SaveEdit

Пользоваться не трундо.
1. Запускаешь прогу
2. Открываешь сейв который хочешь изменить
3. Изменяешь сейв
4. Сохраняешь поверх старого

(Показать/Скрыть текст)
Для вытаскивания из игры полезных идентификаторов

(к примеру для привязки новой брони, или вражеского оружия)используется UModel

UModel - программа для просмотра содержимого файлов .upk
GUI for UModel - графический интерфейс для программы UModel

(Показать/Скрыть текст)
Следует благодарить следующих людей